Outlook 2013で特定の銀行から受信した振込完了メールで、「署名に問題があります」と表示され文字化けする
メール
最終更新日時:2013/03/06 23:57:15
Windows LiveメールやHotmailなどのExchange ActiveSyncを使ったメールの受信時に、デジタル署名がついたメールが文字化けする問題について説明します。
概要
三菱東京UFJ銀行の振込完了メールで、以下の問題が発生します。
- 情報バーに「署名に問題があります。詳細を表示するには、[署名] ボタンをクリックしてください。」と表示される。
右側の署名ボタンをクリックすると「このメッセージのデジタル署名は、無効であるか信頼されていません。」と表示される。 - 本文が文字化けして表示される。
([アクション]-[その他のアクション]-[エンコード] はグレーアウトしていて選択できない)
環境
- Exchange ActiveSync でHotmailを使用
- Windows 8上のOutlook 2013
原因
メッセージの本文は JIS でエンコードして送信され、受信して表示する際はシフト JIS にデコードして表示されますが、Outlook 2013 で現象が発生するメッセージはデータがシフト JIS へデコードされず JIS のまま表示されます。
状況
この問題は、Outlook 2013の問題としてマイクロソフト社が認識しています。
- 同じメッセージを Hotmail のサイトで開いた場合は、署名も本文も正常に表示されます。
- 他の企業からのデジタル署名付きメッセージでも発生します。
対処方法
現時点でのOutlook 2013での有効な対処方法はありません。Gmail等のIMAPでは問題は発生しないため、回避策として、Gmailに転送してIMAP等を利用するしか方法がなさそうです。
関連記事
- Exchange Active Syncで同期しているOutlook 2013の予定表が文字化けする
- Hotmail以外のメールアドレスのMicrosoftアカウントをOutlook 2013で設定する方法
- Exchange ActiveSyncで接続したOutlook.comの差出人の表記を変更する方法
INDEX
コメント
※技術的な質問はMicrosoftコミュニティで聞いてください!